Corrigir: Native bson parser not compiled, please compile or avoid using native_parser=true

oraculum

Tagged: ,

MongoDB

Se estiver instalando o Mongo para usar via Node.JS no Ubuntu dependendo da versão que usar pode receber a seguinte mensagem de error:

Native bson parser not compiled, please compile or avoid using native_parser=true

Para corrigir isso basta mudar o parametro no Mongo indicando que o native_parser deve ser false.

Siga os passos:

1 – Abra a pasta node_modules > mongodb > lib > mongodb > db.js

2 – Localize a linha do código abaixo:

this.native_parser = this.options.native_parser;

Na minha versão é a linha 96, mas dependendo da versão pode ter pequenas alterações.

3 – Adicione antes dessa linha o código abaixo:

this.options.native_parser = false;

4 – Salve e rode sua app novamente: node server.js

 

Share Button

Leave a Reply